Welcome
Top Next

Welcome to the ePSXe Help File.

The ePSXe help file has been created in order to easily combine the official ePSXe readme, the unofficial FAQ by NGEmu and all the hints floating around on the message board and the net. All this knowledge and these informations have been merged into one comprehensive file, which you're looking at right now. Seperated into several sub categories, you should find answers to most of your questions in this documentation.

If you couldn't find any help, don't worry. The ePSXe message board for example is a helpful place, where lots of people know more than we could ever write into such a document, so just ask your question there. However, make sure that your question isn't already answered in this document first.

ePSXe Help File Version 1.1
Based on Informations about ePSXe v1.5.2
Created and written by Bobbi


What is ePSXe
Previous Top Next

What is ePSXe
ePSXe is a Sony Playstation emulator for your PC running under Windows, programmed by calb, Galtor and _Demo_ !

The authors
The programmers aren't new to the scene. The one you all have probably already heard of is _Demo_, one of the authors of the best SNES emulator out there: ZSNES! The other two are calb, experienced programmer from emulators like ESNES, and Galtor, who is new to the emu scene, but still is a skilled programmer.

Technology
ePSXe takes advantage of the popular PSX plugins system, which has been introduced to the scene by PSEmu Pro, a great project which got stopped after a beta got leaked to the public. ePSXe and it's components are all completly programmed in C++. Right now, it doesn't look as if the source might ever get released, but you'll never know.

ePSXe is also being programmed on two OSes at the moment, MS Windows 9x/Me/2k/XP and linux. Although this limits some parts of the program (for example making a proper windows GUI ;)), it's an extreme advantage only having to code changes into one source and getting the results for both platforms.


System requirements

The System you need for good performance often depends on the game you want to play. While for example a game with many complex graphics such as Final Fantasy 9 will require a rather fast PC, you'll be able to play Tekken 1 on a low-end PC already.

During our tests, we noticed a HEAVY difference between, for example, the AMD K6/2 - 500 Mhz processors and the PII 500 Mhz processors. It seems that the slow FPU of the AMD K6-x processors can cause up to 50% less speed than with a comparable Intel processor. The Athlon and Duron processors, however, don't experience this problem any more though.

onestep Minimum system requirements :
P200MMX or compatible
64 MB of RAM
Fast graphic card (like the voodoo 2)
16x CD-Rom
Windows 9x
DirectX 7a

onestep Recommended system configuration :
Pentium II 500 or faster
256 MB of RAM
A fast DirectX or Opengl compatible graphic card, e.g. the NVidia GeForce 2
Fast CD-ROM with good access times
Windows 2000 or XP
DirectX 8

As we said, results may vary. If you're above the recommended system configuration and still have problems, it might either be a bug in the emulator or a mis-configuration. For help with these issues, make sure to check the configuration part in this help file !


Legal stuff

Legal stuff

calb, Galtor and _Demo_ hold no warranties of any kind for this product. You're using ePSXe at your own risk. The authors can't be held liable or responsible for any damage which results from using the emulator, it's plugin or anything described in this documentation in any way.

The official FAQ, this help file, the installer and the Setup Suggestor coming with this packet have all been created by Bobbi from http://www.ngemu.com as an independant project. Neither the ePSXe team, nor the NGEmu staff give any warrenty or take any responsibility for anything this product damages on your PC (although nothing should actually happen).

The graphic, sound, CD-Rom and netplay plugins are developed by independant developers as well, please check the /docs folder coming with ePSXe for all infos about them. Again, neither NGEmu, nor the ePSXe team nor the developers take any responsibility for these files. If you have any issues with this, keep in mind this is a free product, developed in our free time, and we don't get paid for doing this - complaining to us, bugging us about a certain problem or feature you want to see in this product will get you nowhere therefor.

However, suggestions are of course welcome ! If you want to get in contact with the authors or with people who will be able to help you with most issues, a good place to start is the official ePSXe message board , as plugin authors, the ePSXe authors and the NGEmu staff reads this board regulary and will be rather able to help you with your issues.


Version history

Version 1.5.0 is already the 4th update the ePSXe created. With every version, new features get added, more games are working and bugs get fixed. Here you'll be able to browse through the changes being done in the previous releases and, of course, in the current version.


Version 1.5.2

· Fixed a bug which got into 1.5.1 regarding several gte flags (Porsche Challenge, Tomb Raider).
· Partially rewrote the CD-Rom decoder, now it doesn't need custom flags in order to run various games any more.
· Moved the subchannel read options to it's own window in the CD-Rom configuration. Also added a new subchannel reading mode, which works with various LG 852x cdrom drives.
· Fixed a bug in the internal SPU plugin, which has been there since v1.5.0! It caused sound effects to repeat and several games to freeze (BOF series, Soul Blade).
· Added support for the Nero ISO format (.nrg).
· Massive changes to the SIO emulation. It should have better timing now and the F4 trick shouldn't be necessary that often any more. "SIO irq always on" has been removed from the GUI, but you can still turn it on using the F4 key. (affects Silent Hill esp, Track & Field, Metalslugx, NFS5 PAL, Rapshody ...)
· Fixed a bug in the internal ISO reading routines, which prevented some of the last sectors to be accessed.
· As the Chrono Cross trick isn't necessary any more, we have assigned a new trick to the F7 key, for the Xenogears dreams sequence: Press this key at the beginning of the scene, and once again after the end ;)
· Fixes to the CD-Rom decoder and the core, which made some more games playable like, for example, Theards of Fate, NBA Basketball 2000, Legend of Mana, Rebelt Assault 2, Tekken 2, MegamanX series, Jackie Chan US, Michelin Rally Masters, Transformers Beast of Wars ...


Version 1.5.1

· Included partial support for libcrypt games. Libcrypt is a protection scheme used very often in PAL games. It uses data in subchannel q. In order to play your original cd games in ePSXe you need a cdrom reader which works with the read-subchannel routines in ePSXe. NOT every cdrom reader with support for read subchannels will work in epsxe. If your cdrom reader is able to read subchannels but it is not supported by ePSXe, you can use clonecd to read the subchannel to a .SUB file, and copy it in the epsxe\patches directory with the same name than cdrom PS-EXE and with the extension .SUB (SLESXXX.XX.SUB/SCESXXX.XX.SUB/SLUSXXX.XX.SUB..) Since reading from subchannel is slow, ePSXe includes an option in the cdrom config window that you can enable to cache the subchannel to disk the first time you run a game. Of course you can always use some external cdrom plugins, currently only Pete's cdrom plugin supports it. (The support is partial because NOT every libcrypt game is working :(, some non working games include Spyro 2 and 3 PAL, and formula one 99)

Possible choices:

1. If you want subchannel support only from files, select "Enable subchannel support" in the cdrom config window.
2. If you want subchannel support from cdrom, select "Enable subchannel support" and "Enable subchannel read from cdrom." If your cdrom is able to read subchannels in epsxe, a message will be shown in the console between the other init messages.
3. If you want to enable caching of subchannel data to disk the first time you run a game, select "Enable subchannel support", "Enable subchannel read from cdrom." and "Enable subchannel caching to disk."
4. If you have problems reading cdroms after selecting "Enable subchannel read from cdrom." your cdrom is probably not compatible with ePSXe subchannel read routines. Disable this option and try making .sub files with a software like CloneCD.

· Added support for Teac cdrom readers to internal cdrom plugins. (Thanks to Pete)
· Added support for pov hat joysticks. (Thanks to Roberto Paredes by multiples tests)
· Some CD stuff got fixed, like the problem with changing discs, the internal win2k CD plugin CDDA problems and a bug with the ppf support of the internal plugins.
· Fixes to the GTE, which solve problems with 102 Dalmatinas, Rugrats in paris, Destruction Derby 2, Nuclear Strike and possibly others.
· Changed some internal timing stuff, which should produce better (faster) background sound in several games (FF7, Threads of Fate, Valkyrie Profile) (You can use the old timing with -oldtiming)
· Removed the auto detection of game and required BIOS, as this prevented Legend of the dragoon US and Wild Arms 2 US from working.
· Removed the two options -cdinc and -nocdinc, as fixes made them unncessary. In this version -noxaread has not some effect.
· Added support for MDEC transparency, for the Oddworld series, dw4/dw7 battle effects.
· Added support for Capcom MDECs, but you need to use the command line -adjustiming, what will give serious problems with gamepad keys and memory cards (use F4 to fix this problems), and hard slowdowns. (Use this option in your own risk, we recommend to use it only when it will be really necessary).
· Included a new commandline, it is called -nocdoverwrite. It could fix problems with some games like Parappa the Rapper's demo. Sometimes it does the same than -cdtiming.
· LINUX version only: added partial support for external gamepad plugins. Actually only works the lamer0's plugin, which is combined with the internal pad plugin.
· Fixes to CPU and CD-Rom make games like Star Wars - The phantom Menace, Resident Evil 1 PAL, Legend of Legaia, Star Ocean 2, Gran Turismo JAP and Philisoma playable.


Version 1.5.0

· Fixed a bug in MDECs, which caused Metal Gear Solid and Rayman 1 to crash. Furthermore, the MDEC options aren't read from the windows registry any more, so you can only disable them with command lines from now on.
· Rewritten the code what loaded the ps-exe files when starting a game, for a better detection of the games name and the region.
· Added native support for ppf files. Now you don't need to patch the games any more, simply copy your ppf file into the directory "/patches", with the same name than the main PS-exe file in the cdrom (SLES*,SCES*, SLUS* ...), in uppercase. ePSXe will load it on startup then and patch the game in memory on the fly !
· MCI code is now disabled in WinNT/2k/XP, expect when you are using an external CD-ROM plugin which has its own CDDA functions (e.g. Pete's). Furthermore, the external CD-ROM plugins can now play some games like Tomb Raider I and II PAL, what was not possible before due to a bug in 1.4.0.
· Fixed a bug in the internal CD-ROM plugins, which caused some games to hang when they played CDDA sound and later accessed a data sector (Rayman 1)
· Fixed some bugs in savestates. New savestate are not compatibles with old epsxe versions, but the savestates from a savestate from an old version can still be loaded. The command line -ssv0 has been added, which will let ePSXe save the savestates into the old (but buggy) format. (Fixed savestates in square mdecs, and in threads of fate)
· Some games which ran only with a certain bios version, should now run with any (only checked with Legend of Dragon PAL)
· Fixed some GTE bugs. (Looney Tunes: Perro y Lobo, Nhl 99)
· Included a file with help, what can be accessed from help->contents. (Thanks to Bobbi of ngemu.com)
· Last hour changes in internal spu, what fixes Metal gear solid and Valkyrie profile sound, but we have not had too time for test it ;)
· Added a new workaround in order to run Parasite Eve 2 (thanks to Psychojak!). You need to use the command "-pe2". Some PE2 versions are automaticly detected and don't need it though. We didn't play through the complete game though, we we can't tell if it's playable until the end.
· Fixes to the CD-Rom decoder and the core, which make some more games playable like for example Valkyrie profile, Syphon filter series speech, Rayman 1, Micromachines V3, Croc 2, Duke Nukem: Land of Babes, Vrally 2 and Nfs 5 menus, Time Crisis 2 music, Casper Around the World ...
· Multiples games can be played using additional commands like: Rebelt Assault 2 (-noignorecmd), Micromaniacs (-cdtiming), Front Mission 3 (-nocdinc) ...


Version 1.4.0

document Changes coming with version 1.4.0, which has been released on the 25th June 2001 are :

· Included a new wizard guided config, what should do easier configure the emulator.
· Fixed a bug in the internal sound plugin which caused crash on systems using directx8+geforce and some soundcards.
· Fixed a division by zero bug in the gte routines that started in version 1.2.0. It solves the problems with Xenogears, Metal Gear Solid and Final Fantasy 7.
· Added the extension .img (clonecd) to the load iso function.
· Fixed a bug detecting the name of some games, it is used to detect the format (pal/ntsc). (Metal Gear Solid Pal)
· Fixed a bug in the function CDROpen. Fix the psemupro iso plugin.
· Added support to the cdplayer included in the playstation bios, you can listen to your cdda with epsxe now :)
· Fixed some problems with the bootstrap of the playstation.-nogui should not be needed anymore. (Destruction Derby Raw pal, Breath of fire 3)
· Fixed some gte problems. (Vandal hearts 2 pal, Wipeout series)
· Fixed a mdec decoder bug. (Xfiles)
· Added preliminary support for netplay plugins. (Cyberpad)
· Now it is possible to change the memcards file in any moment of the game. (Of course you shouldn't change the memcard while the game is writing it, like in a psx ;-)
· Fixed some problems with the change disc function. (Metal Gear Solid)
· Included support for a new feature included in the video plugins, it now shows a mini-picture from the savestates when you use the F2 key to increase the selected save slot. (It works only with savestates done with the version 1.4.0 or superior)
· Fixed some problems with the XA sound effects and background XA sound which fix Silent Bomber, Megaman X5, Castlevania SOTN, Bloody Roar 1, Dinocrisis 2, and more.
· Fixes to the CD-Rom decoder and the core, which make some more games playable like for example Incredible Crisis, Simpsons Wresting, Threads of fate, Tomb Raider I and II (pal), Fighting Force 2 and so on ;)


Version 1.2.0

document ePSXe version 1.2.0, which has been released on the 7th March 2001, came with the following changes :

· Added better analogic pad emulation and force feedback.It is now possible to configure the analogic axis and the effect of the force feedback motors. (Many thanks to Alex7 and to www.burutter.com, for donating a very nice psx to usb pad converter and giving help on adding support for it).
· Now ePSXe includes savestates support. F1 = save state, F2 = increase slot (max = 5), F3 = load state. The savestates are compressed and saved to the sstates directory, with an average size of 1.5Mb. (WARNING!!! In release date it is supported only in the following plugins: Lewpy Gpu, Pete Gpu, Pete Spu and ePSXe Spu, support will be included in more plugins soon by the plugins authors)
· Partially re-writen the internal spu, it should be faster, have less sound glitches and better sound quality.
· Optimizations added in gte, mdec and core which makes some games work some fps faster than before.
· Fixes to the CD-Rom decoder and the core, which make some more games playable like for example Gran Turismo, Resident Evil, Ape Escape, Kingley Adventure, Legend of Legaia (use the "-legaia" command line), Final Fantasy IX PAL and so on ;-)


Version 1.0.1

document ePSXe v1.0.1 changes are :

· A completly re-written MDEC engine, which should give you better quality and some more FPS during video playback.
· More accurate timing, what means that videos should pause less. (MDEC timing should always be turned ON now). Included two new internal CD-Rom plugins : One for WinNT/Win2k users, which uses WinNT/Win2k's native functions, and an ASPI CD-Rom plugin for Win9x and Win2k users, which is usually faster than the older plugins.
· Fixes to XA sound playback in the internal SPU plugin.
· Included NTSC/PAL auto detection for a more accurate timing, mainly in Square videos.
· The ISOs are loaded directly now, without showing the BIOS logo.
· Added support for PSX mouse emulation. (Selectable in Config -> Controller)(*)
· Added support for PSX analog pad emulation using Analog Pads or mouse. (selectable in Config- > Controller) shortcut
· It's now possible to disable the pads; this is necessary for some games which are only playable for 1 player. (qbert)
· Included a new memory card selector, which comes with support for the most important memory card formats (.MCR, .MEM, .MCD, .GME)
· Memory cards are saved now when you go to the main window and when you exit the emu incorrectly. It's still highly recommended though to close down the emu using the File -> Exit option ;-)
· Added an experimental "Change discs" option. To switch a disc, you need to go to File -> Change disc. (this isn't working with some games yet though). ePSXe should work better with Lewpy's plugins now, so no more crashes when you exit the emu. The reset/continue functions should also work now on several videoboards.
· Fixes to the CD-Rom decoder and the core, which make some more games playable like for example Final Fantasy 9, Grandia, Fear Effect, Tenchu 2 and so on ;-)
· Added a snapshot maker in key F8. (you need the "snap" directory).
· Since we haven't been able to fix the Chrono Cross bug yet, we added a workaround, which can be activated using the F3 key while the game freezes at that point (though this doesn't fix the status screen problem yet, you must still use the cheat code for this)

shortcut We have created a system, where you can either use one digital pad and one mouse or one analog pad. You can change between those using the F5 key. We contacted the GPU plugin authors, so in the next version of their plugins, there should be a flag displaying the type of pad you have currently selected.


Tab "File"

The File menu basicly allows you to launch the different types of formats, which are supported by ePSXe. Below is a list of these and what each of them actually does and when you should use them :

Run CDROM
This option will start the emulator with the PSX CD you inserted into the configured drive (see Choosing and configuring the CD plugin for more infos). By the way, ePSXe doesn't make a difference between backed up CDs and original PSX CDs.

Run ISO
An ISO is a 1:1 copy of a CD, just that it's stored on your HD. This means that you'll get faster access times and better loading times (highly recommended for games reading frequently from the CD). ePSXe supports CDRwin ISOs (.bin) and CloneCD images (.iso).

RUN PS-EXE
This option is mostly meant for developers or demo programmers who want to try ePSXe with the demos (these are NOT demos of PSX games, but rather technical demos !) floating around on the net.

Run BIOS
Allows you to execute the BIOS only, which does about the same as starting the PSX without inserting a PSX CD. You can access the memory card manager and the CD player from here.

Change Disc >
Option for games coming on several discs like Metal Gear Solid 2 or the Final Fantasy games. Doesn't always work, so make sure to save your game before using it.

Exit
Closes the emulator.

None of the options will work before you haven't configured all of the emulators options. For further infos on how to configure it, make sure to check out the Getting started section in this help file.


Tab "Run"

The Run dialog is only useful at runtime, not before starting the emulator (as seen in the above screenshot). The possibilities in this menu are as follows :

Continue (game)
During gameplay, you can always press Esc to pause the game. Using this option you're able to continue again.

Reset
The reset option completly restarts the game you're currently running. Keep in mind you'll loose all unsaved data when using this option !

Save State
One of the best features coming with ePSXe, completly described in Features > Save states ! With this option you're able to save the current progress of your game to your HD instead of saving to a regular memory card. Such a save state usually takes between 1 and 3 MB, and allows you to save ANYWHERE in the game. There're 5 slots available with this option, but you can also use the shortcuts to access this function.

Load State
Same as above, just that it loads the previous created save state.


Tab "Config"

The Config menu is one of the most important parts of ePSXe. In here, you're able to configure the various parts ePSXe has, like graphics, sound, CD-Rom, controllers and much more. Below is a short list of the different functions. If you need more detailed informations, make sure to check out the links given in the descriptions.

Wizard Guide
This option launches the internal ePSXe wizard guide, an easy yet powerful tutorial, which helps you with configuring ePSXe. After you've gone through that one, all options are basicly configured. However, you can still change them in detail with the other options in the config menu.

Video
Includes options to configure ePSXe's graphic output. Since ePSXe is based on the PSEmu Pro plugin standard, nearly all options in there depend on the video plugin you've selected. To add a video plugin into the list, make sure you copied it into ePSXe's /plugins folder, and ePSXe will automaticly add it to the list.
For more informations about the video, make sure to check out the Getting started section in this help file !

Sound
Same as video, just for sound output. More infos are also available in the Getting started section.

CD-Rom
You guessed it, same as video and sound, this time for CD-Rom access. However, it's also possible to play without a really configured CD plugin, as ePSXe also comes with a built in ISO function. For more infos about that one, make sure to check out the Features section.

BIOS
A small but important part in the ePSXe config is the BIOS. This file doesn't come with ePSXe, neither will you find it on the official homepage or on the forums. To get it (it's a file called SCPHxxxx.bin, where xxxx is replaced by a number), you'll have to search the net. Please don't mail anyone about where to get this file. In the config screen itself, you can choose one of your BIOS files for usage.

Netplay
One of the most promising features certainly is netplay. In this dialog, you can select a plugin (currently, the only available netplay plugin however is CyberPad , available from it's homepage. For more informations, please refer to the CyberPad readme, which gives detailed infos on configuring and using it.

Memory card
This function allows you to choose the memory card you want to use with ePSXe. Lots of different formats are supported, like the bleem!, VGS or PSEmu Pro format. Just choose your memory card, and it'll get converted. onestep Notice: It's good to backup your memory cards when working with save states and memory cards at the same time !

Game Pad
Configuration of the controllers. Also includes the possibility to activate force feedback and analog controllers. For more infos, check out the Features section of this help file !


Tab "Options"

Only few possibilities are actually offered by the Options menu. In here, you can set two things :

SIO irq always enabled (F4)
A rather important function in previous versions and still required from time to time in the new versions is the SIO irq. When you're not able to load or save a game, or when no key can be pressed any more, activating this function (using the shortcut F4 is the easiest way to do this) usually solves the issue.

Country
While ePSXe should normally be able to automaticly detect the region of a game, you're still able to choose yours from this menu.


Tab "Cheat"

Last but not least is the Cheats tab. In there, you're able to load, add or edit cheats. However, this doesn't mean that you can apply cheats to get more life or more money in a game, these are internal cheats which allow certain games to run. For more infos about which cheats are required for which game, make sure to check out the Specific Games section of this help document.


Step 1: Necessary files

First off, you need the emulator, all plugins you want to use and the BIOS itself. You can get the first two combined in a nice Installer from NGEmu (browse to http://www.ngemu.com/psx/epsxe.php?page=download). If you already got some files, you can also download everything seperated from the package using the above URL.

We won't supply you with URL's for the BIOS as it is copyrighted by Sony. But you should find it easily by browsing the web, with a search engine like Google for example! Please do NOT mail the authors and do NOT ask on the ePSXe message board about these files, you'll most probably just get banned for doing that.

Next steps are to select and configure the plugins !


Step 2: Graphic plugins

When going after compatibility, you should use Pete's Soft GPU plugin, it's the one with the highest compatibility. When that one doesn't work with a game others have gotten working, you've probably made a configuration error. You should also use this plugin when you've got troubles getting certain game situations to display properly (for example the FF8 battle menus). Now here's a list for the best plugins for the most popular graphic cards:

3dfx Voodoo 2...............Lewpy's Glide plugin (could crash with certain drivers)
3dfx Voodoo 3...............Pete's D3D (DirectX 7) or Lewpy's Glide plugin
3dfx Voodoo 4/5............Pete's D3D (DirectX 7) or Lewpy's Glide plugin
ATI Radeon...................Pete's OpenGL plugin
ATI Rage 128/Expert......Pete's D3D (DirectX 7) plugin
nVidia GeForce 1/2........Pete's OpenGL plugin
nVidia TNT/TNT2............Pete's OpenGL plugin
Matrox G200/G400.........Pete's D3D (DirectX 6) plugin
the rest.........................Pete's D3D (DirectX 7) plugin

You can download all these plugins from the NGEmu plugins page !


Step 3: CD plugins

Windows 9x/ME + IDE CD-ROM
ePSXe CDR ASPI Core 1.2.0 (Requires an ASPI layer, Win9x/ME comes with one.)

Windows NT/2000 + IDE/SCSI CD-ROM
ePSXe CDR WNT/W2K Core 1.2.0 (Does not require an ASPI layer.)

In general
A great plugin overall is Pete's CD plugin. With different modes, auto-detection and many features, it's one you should certainly try out!

Remember that you need an ASPI layer to get ePSXe reading CDs with OTHER plugins using Windows 2000. You can get more infos on this further on in this FAQ!

When those settings aren't working for you, one thing you can do is to create an ISO from the original CD using a burning app like CDRWin or WinOnCD. Keep in mind that you should get better performance using an ISO, compared to running a game from a CD.


Step 4: Sound plugins

The sound plugin is rather difficult to choose. However, below are some recommendations by the NGEmu team. HOWEVER, keep in mind that results may vary !

ePSXe SPU Core: Good plugin, but only decent speed and few options
Pete's DSound plugin: Lots of options, good speed - a good plugin!
Eternal SPU: THE plugin to try, as lots of skilled SPU programmers made it.

You can get all listed plugins on the NGEmu SPU plugins page !


Step 5: The BIOS

Before ePSXe 1.5.0, it was possible that a certain BIOS file had a better compatibility than another one, but the programmers soon found out that this is related to a bug in the emu, not the BIOS providing better compatihility.

ePSXe has been mainly tested with the SCPH-1001 and the SCPH-7502 BIOS files, which are therefor the BIOS files we mostly recommend. Again, do NOT ask the authors or anyone else for the BIOS, in most cases this will just get you in troubles.


Step 6: Misc settings

Now that you've selected and configured the plugins of your choice, here's a list of the rest of the settings and how we recommend you to set them. Still, some game require different settings.

Options
onestep SIO IRQ Always Enabled
[DISABLED] - (F4 to toggle on/off)
Config
onestep CD-ROM
onestep Enable Accurate CD-ROM Timing
[DISABLED] - (See notes in the GUI)
onestep Enable no cdrom param overwrite
[DISABLED] - (See notes in the GUI)
onestep Enable subchannel support
[ENABLED] - (only if your CD-Rom supports this - check "Features")
onestep Enable subchannel read from cdrom
[DISABLED] - (only works with few CD drives, check "Features")
onestep Enable subchannel caching to disk.
[DISABLED] - (enable if you want to create subchannel files)
onestep MDEC
onestep Enable MDEC
[ENABLED]
onestep Enable MDEC Timing
[ENABLED] - (See notes further down)
onestep Sound
onestep Enable Sound
[ENABLED]
onestep Enable CDDA Sound
[ENABLED]
onestep Enable XA Sound
[ENABLED]
onestep Enable XA Read
[ENABLED] - (Needs a fast system, F6)
onestep Enable SPU IRQ hack
[DISABLED]

And now you should be able to enjoy one of the best free emulators out there. When you still have problems or suggestions for this FAQ, feel free to post them on our message board or mail us!


Save States

Starting with version 1.2.0, ePSXe has save state support. While an improovement has been made for version 1.4.0 (savestate pic support), the format didn't change. Starting with version 1.5.0, you'll need to run ePSXe using the -ssv0 option if you want ePSXe to create save states in the old format - otherwise you won't need this option.

What is a save state ?
A save state is an exact copy of the memory ePSXe uses (and therefor the PSX would use), which allows you to save your exact position in the game - unlike memory cards, which only allow you to save when the programmers actually want you to. Advantages are obvious, as you can save before a difficult place so you won't have to replay lots of stuff just to get back to that point.
A save state usually has a size between 1 and 3 MB (and that's already compressed!) depending on the stuff which has been in memory when you saved and, of course, the game itself.

How to use save states:
Of course you don't have to use ePSXe's menu all the time (see: The GUI ), ePSXe has some shortcuts which make it easier to manage your states. Just use the following keys :

onestep F1 = Save the game to the selected slot
onestep F2 = Switch one slot higher (max. 5 slots are available)
onestep F3 = Load the game from the selected slot

Most GPU plugins also are able to display the currently selected slot on their "on the fly" menues. You can usually activate these with the 'Del' key. For further infos, refer to the plugins readme.


Dual Shock

About Dual Shock
One of the features ePSXe offers is Dual shock emulation, converted over to what PC users know as Force Feedback ! To take advantage of this feature, you'll either need a PC joystick supporting Force feedback, or one of these neat PSX to PC converters, which come with rumble support.

Configuration
In order to configure the rumble feature, you'll have to go to the Game Pad menu, and open the controller you want to rumble. On your right handed side, you'll now see three options to configure : The type of your rumble controller (ePSXe comes with built in Burutter support for example), and the force with which the motors are supposed to rumble.

If you can't get the rumble feature to work correctly, make sure to take a look at the Troubleshooting section of this help file.


Sub channel reading

First off, let's clearify what the heck we are talking about here : Sub channel reading basicly allows you to get around many protections without getting a PPF file to patch the emulator. This is mostly interresting for NTSC J (japan) and PAL (europe, asia) users, as these versions of the game often come with such a copy protection (the most popular example would be Final Fantasy 9 here). The new option just needs to be activated in ePSXe v1.5.1 and you're settled. Now below is a detailed text, written by Pete Bernert (author of the famous Pete plugins collection), which gives you about any detail you might know (even some which rather belong into the documentation directory), so I just pasted it in here :

First let me try to explain in an easy way what "subchannels" are for: Beside the "real data" in a cd sector, there are also a few extra informations for each sector. That extra informations ("subchannel data") are usually used on audio tracks, to give informations about the current head position (unlike a data track, an audio track needs all bytes in a cd sector for the audio data, so there is no space left for sync infos or error correction infos... but in the q subchannel there is a track number, an index number and even absolute/relative timestamps, so the audio cd player can use that for synchronisation while playing cd audio).

The subchannels are also present on data tracks, even if no file system will need them... and once-upon-a-time game companies had a "great" idea for copy protections: usually the timestamp in subchannel data will give the position of the playing position... but data tracks don't need that info... so why not abuse the data? Why not change, for example, the timestamp of a few special data sectors to some nonsense values? The game can read back the subchannel of that sectors, and detect illegal cd copies that way (since most cd writers will write correct timestamps, and not the "nonsense" ones of the original cd).

OK, now I can hear the questions of many users, asking "so what's the problem? I only use original games, so I don't care about copy protection issues."
Unluckily that's not true... unlike the psx cd drive, there are some problems reading subchannels on pc drives. The 'official' scsi commands for reading subchannel data will give you not the exact sub q data of a sector, the values are usually from a +/- 1 second wrong sector (that's because the command was designed to give only rough position infos for audio playing, nothing else).
There _are_ vendor-specific subchannel read commands for most drives, but the vendors are not giving such informations easily to interested users (I am really wondering why... hell, it's my drive, and if it can read such data, and if I want to use it to do that, why refuse to give me the required informations? And next time when I buy a car, I prolly will not even get the keys for it, pfff).

So, in the past, users of _original_ but copy-protected psx game cds had to search the net for special game PPF patches (which removed the protection), if they wanted to play such a game in an emulator. Not very nice, isn't it?

The first emu team which tried to get around that situation was FPSE, afaik...FPSE 0.10 was never released, but LDChen (main coder of FPSE) claimed he had some copy-protected games up and running, without any PPF patches (and I have no doubts about that... prolly he had found a command on his cd drive, which was reading the subchannel data).

Well, lately more emu teams were trying to emulate copy protected games (to freely quote lu_zero: "Cheats and hacks are bad! Only real emulation is the true way!"), and so I (as the creator of this small cdr plugin) was forced to try my luck with subchannel reading as well :)

"Pain in the ass" doesn't describe my cdr coding sessions... it was a more overall pain, I can assure you ;) But with much talks and more tests between the members of various psx emu teams (hi to calb, _Demo_ and shunt), I can now proudly present version 1.10 with subchannel support.

So, now let's move to the new options:

1. there is a mode called "Don't read subchannels". If your game doesn't have a copy protection, use that one. That mode will work like the previous versions of my cdr plugin, no loss, no gain.
2. A mode called "Read subchannels". Go figure ;) Well, I advise NOT to use that mode, ehehe. Confused? Aahhh... lemme try to explain: I've coded four different sub channel read modes (one is working on my Pioneer in BE_2 scsi read mode, one is working on my Teac in combination with the 28_1 mode, one is using the standard scsi "read subchannel" command (gives not the exact values on my drives), and one is only available in W2K/XP (and also doesn't give exact values on my drives). But all of them will SLOW DOWN the cdrom access (well, the BE_2 mode is kinda OK, but the teac mode has the same effect as a FPS limitation to 3 FPS if a game is accessing the cd all the time). And I've noticed that a randomly accessed subchannel reading of sectors can lead to some wrong bits in the subchannel data from time to time, due to the lack of some error correction... bad thing! So, that leads us to the 3. RECOMMENDED mode:
3. "Use subchannel SBI/M3S info file". What's that? Easy: the plugin will only do the normal, fast data reading (like mode 1), and everytime when a game wants to have subchannel data, the plugin will use the subchannel data stored into a file on your harddisk. So, you just have to create a subchannel info file of your copy protected game one time, and activate that file in the plugin if you want to play that special game (that's when a frontend like ePSXeCutor comes handy, for creating different game configs, ehe :) So, it kinda works like my PPF option, but of course you can create your own info files, you don't need the help of some cracking crew =)

How to create such subchannel info files? Easy as well: there is a special button in the cdr config window, which will let you create the files directly from your original cd, or (if your drive is not supported by my subchannel reading funcs), you can convert a CloneCD SUB file... of course you will need CloneCD as well to do that, but it's the only way to get the subchannels from a drive not supported by my plugin (and prolly there are many not supported drives...)

I support 2 different subchannel info file types: a format which is also used by epsxe, called "M3S". This files will ever be 71 kbyte in size, but they don't contain _all_ subchannels from a game, just the ones of the minute 3 sectors... usually that's enuff for psx copy protections, but to be sure I made my own file format as well, called "SBI". That one will contain all "nonsense" datas from track 1 of a game cd, so the size will vary (usually it's small, though, only 5 - 20 kbytes). It takes more times to create "SBI" files, well, so it's up to you :)

Ok, so you have created the subchannel info file, you did configure the plugin to use it... and still the game doesn't work??? Why??? First: the main emu has to support the new subchannel commands... if it doesn't, it will not work. At the time I am typing that text only ePSXe 1.5.1 can be used with subchannels, but I am sure that more emus will follow... so stay tuned =) Second: There is an option called "Enable subchannel support" in ePSXe 1.5.1 (and in ePSXeCutor 1.0.5.1 as well, of course). You have to ENABLE that epsxe option, or otherwise epsxe will NOT use the subchannel data.


PPF patching

Starting with ePSXe v1.5.0, ePSXe comes with an option to apply PPF patches to your game on the fly, as already seen in Pete's great CD plugin. NGEmu made a collection of important PPF files for you to download, but searching the web you should find plenty more. Using them is a bit more difficult, but easy once you got the system, and understandable for everyone who follows the step-by-step instructions below :

1. Download (and possibly unzip) the PFF patch EXACTLY for the game you'd like to patch. That means that you won't be able to use a PPF patch for FF9 german with your italian version ! Also keep in mind that some games (like Gran Turismo) have two versions.
2. Copy the file into the /patches sub-directory in your ePSXe directory
3. Look on the CD you want to use ... you'll find a file whose name is like SLES*,SCES* or SLUS*. Copy that name and rename the PPF file from your /patches directory to exactly the same name (also in uppercase !).
4. You're done, the next time you run that game ePSXe will add the patch on the fly !

Please do not ask any of the team members to mail you a certain PPF file, these requests simply will be ignored. Asking on the forum might get us to upload one, but don't count on it.


Command line switches

There are quite a bit of undocumented switches, even some that aren't mentioned when using the '-help' switch! For your reading pleasure, here is a list of all known command-line switches in ePSXe 1.2.0 and their function(s) (big thanks to CDBuRnOuT for his re-search on this !!) :

· -adsrtrick............................Returns a random ADSR value.
· -analog...............................Enables Analog Pad Emulation.
· -anamous...........................Enables Analog Pad Emulation via Mouse.
· -bios <file>..........................Loads the specified PlayStation BIOS file.
· -c.......................................Enables the Dynarec core.*
· -cddmairq3..........................Enables CD-ROM IRQ3 in DMA.**
· -cdfast................................Enables Fast CD-ROM Emulation.
· -cdrom <letter>...................Selects a CD-ROM Drive Letter
· -cdslow..............................Enables Slow CD-ROM Emulation.
· -cdtiming............................Enables Accurate CD-ROM Timing.
· -debug................................Enables Debugging (only in betas!)
· -dmairqclear........................Forces DMA IRQ to always be cleared.
· -f........................................Disables BIOS Logo. (Fast Boot)
· -ff9pal.................................Enables Final Fantasy IX PAL cheat.
· -fl.......................................Enables the internal framelimiter.**
· -forcepad............................Forces SIO IRQ to always be enabled.
· -forcespu............................Forces SPU IRQ to always be enabled.
· -gun...................................Enables Namco Gun Emulation.**
· -h......................................Displays some (not all) command-line switches.
· -hdev.................................Displays a list of debug options.
· -help..................................Displays some (not all) command-line switches.
· -i.......................................Loads the Interpreter core.*
· -legaia................................Enables Legend of Legaia cheat.
· -lib.....................................Loads libpsx.exe.
· -loadbin <file>.....................Loads a specified ISO image file.
· -loadcheat <file>.................Loads a specified .cht file.
· -loadfake............................Loads a fake file.****
· -loadmemc0 <file>..............Loads a specified memory card file in the first slot (0).
· -loadmemc1 <file>..............Loads a specified memory card file in the second slot (1).
· -mouse..............................Enables Mouse Emulation.
· -noaudiocd.........................Disables CDDA.
· -noauto..............................Disables automatically applied patches.
· -nocd.................................Disables CD-ROM Emulation.
· -nocdcmd11.......................Disables CD-ROM command 11.
· -nocdstatus........................Changes some CD-ROM status outputs.
· -nocdrtstatus......................Disables CD-ROM RT status
· -nogui................................Runs ePSXe without the GUI.
· -nolog................................Disables log files.
· -nomdec............................Disables MDEC.
· -nomdectiming....................Disables MDEC Timing.
· -nomemcard.......................Disables Memory Card Emulation.
· -noseekinxa.......................Disables seeking during XA playback.
· -nosound...........................Disables Sound Emulation.
· -p <num>..........................Adds penalty cycles to memory access.*****
· -paddual............................Enables a pad workaround*
· -savefake <file>..................Saves a fake file.****
· -ssv0.................................Creates savestates compatible with ePSXe v1.4.0
· -v......................................Shows the current version of ePSXe
· -xaread..............................Enables XA Read.
· -xasound............................Enables XA Sound Emulation.
· -[psx exe]..........................Runs the specified PSX Executable (can be a .pll, zipped)

For infos which command line switch is required for which game, check the Specific games section !


Problems running a game

This is a pretty big area. First off, you should check if there is any advice on running your game in the Specific games section of this help file. If you can't find it in there, checking NGEmu's compatibility list might tell you if the game is known to not run or having problems. If it isn't listed, there're still some things to do before giving up though.

Game not starting at all
First off, you could use another plugin, since not all plugins work with every game. We suggest you use Pete's plugins for GPU (OpenGL, D3D or Soft), since they provide the best compatibility ... see the Getting started section for more plugin troubleshooting. Then, you could try to disable MDECs, since some games crash when they try to show the opening movie. In case you're running the game from an ISO file, try Daemon Tools, since some games only work properly with that tool. Some people also informed us that using a different BIOS version has helped them getting the emu working. Now, check if your CD-ROM drive at least TRIES to read the game CD ... when it does nothing on start, try another plugin (see plugins section for more help). If this isn't the problem, you can try to load the game patches using the "Cheat" option in ePSXe. Some games have special workarounds found in these patches with allow them to run, or fix some in-game bug. And last but not least, you should try to start the emulator with the option '-cdtiming' or activate the "Enable Accurate CD-ROM Timing" option in the CD-ROM configuration screen.

Problems with controllers
In games like Driver, Ridge Racer, Street Figher etc., it might happen that you just aren't able to control anything. To get the controller working again, you just need to enable "SIO IRQ always on" in the misc menu or simply press F4 during emulation!

If all this didn't help, you just need to wait for the next version, but hey, this emulator is free so please don't send any E-Mails to the authors asking for game X to work in the next release.


ePSXe randomly crashing

One thing that ePSXe seems to be really sensitive to is bus speeds which are out of spec. This means you most probably overclocked your PC. If you are experiencing problems with ePSXe crashing constantly, but never at the same location, then it could be pointing to this problem.

The only way that your bus speeds would be out of spec would be if you are overclocking, so if you are then you might want to try setting your processor back to its default settings with the PCI bus being at 33mhz and the AGP bus being at 66mhz. During testing the bus speeds only seemed to effect Final Fantasy IX, but it might also effect other games as well, so if you are having random crashing problems with any game, this would be something to give a try.


Input problems

DirectX issues
First, make sure you are running DirectX 7.0a or 8.0a, as versions 7.0 and 8.0 have DInput problems which were fixed in their 'a' counterparts. You can get the lastest DirectX from http://www.microsoft.com/directx If that doesn't fix your problem, delete the ePSXe Configuration registry entry under 'HKEY_CURRENT_USER\Software\Epsxe\Config' using Microsoft RegEdit, if you find that too hard, I suggest a powerful, yet easy to use registry editor, RegCleaner (http://www.jv16.org ). After deleting the entry, reconfigure your controller (and everything else =P) in ePSXe.

Problems with Force Feedback (answer provided by Wormie )
Some people seem to have troubles getting Force Feedback to work for them. During testing, we found out that this feature only works when the controller is set as analog/digital in ePSXe's controller setup. Also, when setting up the analog controlls, messing with the options at the very bottom of the controller config screen is a bad idea - just setup the 4 way directional pad area with the analog stick instead of the directional pad.


Speed issues

Too slow
If ePSXe is running to slow for you, there're several things to check. First off, is your system applying to the system requirements at all ? You can check this in the Introduction part of this documentation. Then, some people seem to forget that activating all these funny switches and increasing all the options to max. *may* slow down their PC. Check your graphic plugin and set your resolution, color depth etc. to a lower value. Some plugins come with pre-defined configs, it may also be a good idea to try out these. Trying another plugin is also a possibility, check out the Getting started section for more details about these.

If this didn't help, remember that ePSXe is very ressource intensive. Closing down all programs running in the background / systray, can therefor give you a nice speed increase.

Too fast
If you're using Pete's GPU plugins, check off the 'Use FPS Limit' checkbox, and select 'FPS Limit (10-200)', and manually define your FPS limit, it is recommend you input 60fps for NTSC J and U/C games, and 50fps for PAL games. If you need a little speed boost, try incrementing the fps by a bit, maybe by 10 or so.

If you're using Lewpy's Glide GPU plugin, select the 'FrameRate Limit' option, choose 'Custom', and put 60fps for NTSC J and U/C, and 50fps for PAL. If you feel it's a bit slow, try boosting the speed a bit by incrementing the fps a bit, I suggest 10fps or so, but your mileage may vary.

If you're using Knack's Software GPU Plugin, select the 'fps limit only' option under the 'Framerate > Adjustment Type' menu. It's automatic, as far as I know, there's no way to customize it, yet ;)


Problems saving

Question : When I save my game using the memory cards after loading a save state, it saves fine, but the save data is missing/older when I play it the next time, what gives?

1. You start the game in ePSXe and the memcards you have selected in the GUI are used.
2. You make a SaveState - this includes PSX RAM, GPU VRAM, SPU RAM, and memcards (<- important!)
3. You quit ePSXe, go do something really important in RealLife™, and then come back
4. You start the game in ePSXe and the memcards you have selected in the GUI are used.
5. You load the SaveState - here is the problem: what should happen to the memcards? They need to be restored from the SaveState, but should they overwrite the ones that you have selected in the GUI? That _could_ trash some important saves! So the safe route is taken: some memcards called temp.000 & temp.001 are created from the SaveState, and ePSXe then uses those for the rest of the game, until closed.

As another solution, we'd recommend you to backup your memory cards before running ePSXe when you are working with save states - at least until a real solution has been found.


General issues

Problems with CD plugins in Win2k/XP
In order to get ePSXe running correctly under Windows 2000 / XP, you'll need to install an ASPI layer first. If you don't have one yet, you can download one from NGEmu's ePSXe download area - install it and you should be set.

Furthermore, you should use ePSXe's internal CD plugins if you have any problems with others (they're included by default and don't need an extra .dll file in the plugins folder).


Lewpy's Glide plugin

Lewpy's glide plugin crashes when I try to run a game.
You're most probably either using a false configuration or, more common, an outdated version of his plugin. Make sure you grabbed the latest plugin version from his homepage.


Null2's SPU plugin

Although I copied the .dll into the plugins folder, the plugin doesn't appear in the list.

Null2's popular SPU plugin requires the Visual Basic 6 runtimes in order to function properly, and won't even be listed unless they are installed.
Win2K, WinMe, and Win98SE(?) already come with them, but Win95 and Win98 do not. You can grab yourself a copy of the runtimes at:

http://download.microsoft.com/download/vb60pro/Redist/sp4/win98/EN-US/VBRun60sp4.exe


Pete's GPU plugins

The emulator crashes with Pete's plugins and the "Nice" setting on my Voodoo 3.
It's simple: Pete's plugin activated 32-bit color when you press "Nice", and the Voodoo 3 doesn't support anything more than 16-bit color. You need to lower the color depth in order to fix this problem!


Graphic APIs

Because of the PSEmu Pro plugin interface, which ePSXe takes advantage of, it's possible to basicly use any API you could want to use. There are several plugins for APIs such as OpenGL, 3Dfx's glide, Direct3D and the basic software mode. Below are some examples for each API, and who should actually use which :

OpenGL
The most popular and best OpenGL plugins are certainly Pete's OpenGL plugin and NextGL from Nikk. The OpenGL API should mainly be used by people who have NVidia or ATI cards. It provides the best speed and great graphics on these cards.

Direct 3D
Microsoft's DirectX API is widely used. If your card shows bad performance in OpenGL, or if you're using a 3Dfx card, a plugin from this category might be worth trying. Examples are Pete's Direct3D drivers and Nikk's Next3D plugin.

Glide
An old API created by 3Dfx. Around 1997, it was rather popular, and still today some people use their old 3Dfx Voodoo cards. The only reallly useable plugin in this category is Lewpy's glide renderer.

Software
Not really an API but rather non-accalerated is called software. In software mode, you'll get bad speeds but compatibility is the highest and display errors are rare.

You can get the latest plugins for all these APIs from the NGEmu GPU plugins page !


Memory cards

ePSXe also comes along with memory card support. The used cards are saved in 2 files in your \memcards directory. The first one is named epsxe000.mcr and the second one epsxe001.mcr. Each file has a size of 128 KB (which is PSX standard), and the format is simply a dump of real memory cards.

ePSXe doesn't come with a memory card editor, but you can use the option Load -> Run BIOS to get to the real PSX memory card editor, from where you can delete / move savegames. In case you're using Pete's OpenGL / D3D plugins, don't forget to enable offscreen rendering to see this menu correctly.

Starting with version 1.0.1, ePSXe includes a memory card file selector, so you can select which file you want to use in which slot. ePSXe also has support for different memory card file supports, like Dexdrive (.gme), PSEmu Pro (.mc) and several others.

When you'd like to edit your cards, you'll be able to find several tools in the NGEmu's ePSXe download area !


General PSX Bios infos

Configuration in ePSXe
In ePSXe, click config -> bios. In the new window, you can see a text box which shows the currently selected bios and a browse button. Click this button and select the BIOS you want to use. During testing we found out that the scph1001.bin and scph7502.bin BIOS' are compatible, but the scph1000.bin won't work. Please remember you may only be in possession of the copyrighted BIOS when you're legally entitled.

BIOS region informations
To find out your version of the PSX BIOS, open the PlayStation Bios file in WordPad or any other text editor, go down to the bottom and you will see System ROM Version X.X YY/YY/YY (Z).
X is the number of the BIOS, e.g. 2.2
Y is the date of the BIOS, e.g. 12/04/95
Z is what region the BIOS is from, e.g. J for Japan


Dumping the PSX Bios

When you own a real playstation, there's also the possibility of dumping your own PSX BIOS instead of getting it from the internet. Below is a short description, which should give you an idea of how dumping it works. If you're familiar with the utilities being used there, you are already able to dump it. If not, searching the net is again a good idea here !

To dump a PlayStation BIOS, you need a GameShark or Action replay and a PC comms link. To start, you need either a real Caetla module or go to Google (http://www.google.com ) and search for "Caetla" (it's a BIOS replacement for your module, so properly read the included documentation before installing it!!).

Now upload "Caetla", and use use the caetla commands for downloading a binary memory image from the region 0x0bfc00000 - 0x0bfc7ffff! Now save the image as SCPHxxxx.bin, where xxxx is your PSX's model number, and ePSXe will recognise it and use it from now on.


Specific games

Several games require specific command line options, plugins or hints before they'll run at all. In this part of the help file, we try to keep a list of these games and informations how you can get them to work. Possible requirements are :

Specific version
It is possible, that only certain regions of a game are working with ePSXe. A popular example would be Final Fantasy 9 - while the NTSC J (japan) and NTSC U/C (USA) are running just fine, all PAL versions require patches, which are only available for some versions.

Cheats
Games like Tomb Raider for example require you to apply a cheat in ePSXe's internal cheat function, before it's able to run them. This can, for example, be caused by memory problems or other issues.

Command line switches
Games like Parasite Eve 2 require you to run ePSXe with a certain command line switch (in this case this would be ePSXe.com -pe2 for example) in order to run. While this applies a rather game specific fix, it's also possible that you need general fixes.

Specific plugins
Last but not least, some games only run correctly/at all when you're using a certain plugin, which contains a special fix. To learn more about these plugins, make sure to check out the Getting started section in this help.


Breath of Fire 3 PAL

In order to get Breat of Fire 3 (PAL) to start, you'll need to run ePSXe with the command line switch -nogui. So if you, for example, installed ePSXe into C:\epsxe, the full command would look like

chiclet C:\epsxe\epsxe.exe -nogui

This command disables the GUI and will get you directly into the game, so make sure you've configured everything else before.


Breath of Fire 4 NTSC U/C

Issue: Breath of Fire 4 crashes, as soon as you enter Kyria.

Solution: Load the cheat for Breath of Fire 4, located in cheats/breath_of_fire_4_usa.cht using ePSXe's cheat function. If you're not familiar with ePSXe' cheat function, make sure to check out the Features section.


Chrono Cross

Issue: Chrono Cross locks up when I use the teleporter.

Solution: Both 1.0.0, 1.0.1, and 1.2.0 freeze when you use the teleporter in the game, but you can unfreeze it and get past this point by hitting F3 in ePSXe 1.0.0/1.0.1, and F7 in ePSXe 1.2.0 or above.


Cool Boarders 2001

In order to get Cool Boarders 2001 to start, you'll need to run ePSXe with the command line switch -nogui. So if you, for example, installed ePSXe into C:\epsxe, the full command would look like

chiclet C:\epsxe\epsxe.exe -nogui

This command disables the GUI and will get you directly into the game, so make sure you've configured everything else before.


Dino Crisis

Issue: Dino Crisis looks up at the beginning.

Solution: the US (NTSC U/C) version has anti-mod protection, which needs to be removed in order for it to work with ePSXe. This can be done via a PPF patch for the game, which you can get from NGEmu.


Dino Crisis 2

As with Dino Crisis 1, the US (NTSC U/C) version of this game has anti-mod protection, which needs to be removed inorder for it to work with ePSXe. This can be done via a PPF patch for the game, which you can obtain from NGEmu !


Final Fantasy 8 PAL

You need to use a patched backup version, the original one is not working. To learn how to apply the so called "PPF Patches", consult the features section in this help me file, or Pete's CD plugin readme.


Final Fantasy 9 general

Fivefeet8 and Rargh typed up a FAQ containing all kind of problems people experienced. Here is an extract of that FAQ, which lists the most important issues you may encounter :

Q: When I launched ff9, I just get a black screen. Why?
A: If you have a pal version of the game (australian, european, UK), you MUST patch the game in order to run it. (NB: Applying the UK patch on the Australian or NZ version of the game works perfectly). Since ePSXe v1.5.1, there is also the possibility to activate sub-channel reading, for more informations refer to the corresponding section in this help file.

Q: I can't see the battle menus!
A: Activate the Offscreen drawing with Pete's OGL/D3D plugin (enhanced mode would be the best choice) or Activate experimental screen flipping with Lewpy's Glide plugin.

Q: The screen becomes black, but I can still hear the music (or not). What's wrong?
A: There are two possibilities :
1) Using save/load states can sometimes cause this problem, load the game from the memory card and it should work fine.
2) If it isn't working, it could be MDecs related. Untick the "enable MDecs" box in ePSXecuttor to get past through this black screen then, you can tick it on again.

Q: When entering a battle, the "swirling effect" is very slow!
A:
Petes' gpu pluggin: If your videocard isn't fast enough to display this effect, put the framebuffer textures to "black" which will disable the effect.
Lewpys' glide pluggin: Set framebuffer access to "disabled" and Off screen drawing to "basic". This disables the effect. or Set framebuffer access to "write" and off screen drawing to "extra+fbr". The swirl effects will still be enabled but won't slow down as much.

Q: I can't move the cursor at the "new game"/"continue" title screen.
A: While ingame, press F4 or F5 then F4.(also fixes most memcard problems)

Q: The entering battle scene just makes ePSXe crash.
A: Disable the "framebuffer read" box in the special game fixes.

Q: The MDecs and sound during them stutter and sound strange.
A: Make sure you didn't enable spu irq in both the epsxe sound options and the spu pluggin configuration. Enable spu irq in only one place. It is preferable to enable spu irq in the sound plugin configuration.

Q: When I try to enter the tornado to get into Cleyra, epsxe gets stuck at a black screen or crashes.
A: See the second question above.

If you got further troubles, checking out the ePSXe message board (find a link in the links section of this help help) is in general the best idea.


Final Fantasy 9 PAL

Final Fantasy IX PAL needs a patch to be applied to the original CD before it can work with ePSXe 1.2.0 or higher.

There aren't patches for every region yet. You should check out NGEmu to see if your version has already been patched. For more infos about patching, consult the Features section in this manual.


Final Fantasy 9 US/JAP

It isn't playable in ePSXe 1.0.0 due to an emulation bug. Anyway, this bug has been fixed in 1.0.1 and higher :)
When using Pete's hardware (D3D/OGL) plugins, remember to set Offscreen Drawing to standard in order see the battle menus, and set Framebuffer Textures to Gfx Card Buffer (If your video card supports it, check Pete's docs) or Full VRam Primitives (Note: Full VRAM Primitives WILL slow down ePSXe immensely), so you can see the effect which occurs every time you enter a battle.

For more infos about the plugins, consult the plugin readmes.


Front Mission 3

In order to get Front Mission 3 to start, you'll need to run ePSXe with the command line switches -nogui and -nocdinc. So if you, for example, installed ePSXe into C:\epsxe, the full command would look like

chiclet C:\epsxe\epsxe.exe -nogui -nocdinc

This command disables the GUI and will get you directly into the game, so make sure you've configured everything else before.


Gran Turismo 2

In order to play Gran Turismo 2, simply enable 'Accurate CD-ROM Timing' under Config > CD-ROM, or start ePSXe with the '-cdtiming' command-line switch, so if ePSXe is installed in C:\epsxe, your command would look like this :

chiclet C:\epsxe\epsxe.exe -nogui


Legend of Legaia

Issue: The '-legaia' switch doesn't seem to fix the problems in Legend of Legaia

This was an error on the authors' part, the correct switch to use via command line is '-cdtiming -legaia'. NOTE: Enabling Accurate CD-ROM Timing in options may produce the same effect, but to be safe, it's best to use the switch. Your command would look like this if ePSXe is installed in C:\epsxe then :

chiclet C:\epsxe\epsxe.exe -cdtiming -legaia


Megaman X4

In order to have the music playback properly, start ePSXe with the command-line switch, '-noseekinxa', so your command would look like this :

chiclet C:\epsxe\epsxe.exe -noseekinxa


Micromaniacs

In order to run Micromaniacs, you'll need to use the command line switch -cdtiming. Therefor, your command would look like this :

chiclet C:\epsxe\epsxe.exe -cdtiming


Parasite Eve 2

Since ePSXe v1.5.0, there is a special fix coming with ePSXe which allows you to run Parasite Eve 2. First off, you should try to run it normally. When you get stuck at the Squaresoft logo, you'll need to use the '-pe2' switch, so your command would look like this :

chiclet C:\epsxe\epsxe.exe -pe2

However, we haven't played the game until the end yet, so we can't really tell you if it's 100% compatible.


Rebel Assault 2

In order to run Rebel Assault 2, you'll need to use the command line switch -noignorecmd. Therefor, your command would look like this :

chiclet C:\epsxe\epsxe.exe -noignorecmd


Resident Evil 3 PAL

In order to get Resident Evil 3 (PAL) working, you'll need to apply a PPF patch to it. To get one, head over to NGEmu and locate the PPF download area ! For further informations about PPF patching, check out the Features section !


Saga Frontier 2 PAL

In order to play Sage Frontier 2 PAL in ePSXe, you will need to do two things. First off, you have to patch it using a PPF patch, which you can find over at NGEmu ! Then, you'll need to run ePSXe with the '-auto' command, so your command would look like this :

chiclet C:\epsxe\epsxe.exe -auto


Shadow Madness

In order to run Rebel Assault 2, you'll need to use the command line switches -cdtiming and -nomdectiming. Therefor, your command would look like this :

chiclet C:\epsxe\epsxe.exe -cdtiming -nomdectiming


Soul Reaver

This one is rather easy, simply check off the option 'Disable Real-Time CD-ROM Status' under Config > CD-ROM in ePSXe.


Spiderman

In order to get correct graphics in Spiderman, you'll need one of Pete's GPU plugins, as they come with special fixes for this game.


Tony Hawk Skateboarding 1

In order to get correct graphics in Tony Hawk Skateboring, you'll need one of Pete's GPU plugins, as they come with special fixes for this game.


Tony Hawk Skateboarding 2

In order to get correct graphics in Tony Hawk Skateboring 2, you'll need one of Pete's GPU plugins, as they come with special fixes for this game.


Useful links

In here I gathered together a collection of useful links for using ePSXe. There, you'll find help, files and further informations on this emulator, so they're all worth checking somehow:

ePSXe Homepage - http://www.epsxe.com
ePSXe message board - http://www.ngemu.com/forums/forumdisplay.php?s=&forumid=7

NGEmu's PSX plugins page - http://www.ngemu.com/psx/plugins.php
NGEmu's compatibility list - http://www.ngemu.com/compat/index.php
PSXFanatics' compatibiliy list - http://www.psxfanatics.com/....

NGEmu - http://www.ngemu.com
PSXFanatics - http://www.psxfanatics.com


Credits
Previous Top

Of course it wasn't possible to create such a large document all on my own. Many people helped and supported me during it's creation, of which I'd like to name a few below:

CDBuRnOut
Helped a lot by creating the original 'Unofficial ePSXe FAQ', which was the base for many stuff you'll find in here.

calb, Galtor & _Demo_
All three were really helpful whenever a question was there which I couldn't find an answer to myself. Furthermore, they're the people responsible that this document exists at all, as they made the emu it's written for ;)

Thorgal
Without him, there would be no NGEmu - and without NGEmu, there would be no help file ! Go figure ;)

Wormie and Sandie
Two really cool friends, also running a great PSX site called PSXFanatics !

Yoshi
Annoying me so long at work (and at home and everywhere else), until I started this work just so he shuts up.

Emuforums members
Lots of questions and answers do come from our board, and I'd therefor like to thank all the people who help out there each and every day, and who made this big collection of useful hints and tricks possible !

Written by Bobbi of NGEmu.com
Hope you enjoyed reading ;)